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Preliminaries

0.1 Quick Start?

If you’re new to the Bantam Tools NextDraw, and want to get up and running 
as quickly as possible, here are the most important parts to know about:

1. Follow section “1.2 Unboxing NextDraw”, starting on page 10.
	 This section covers a couple of initial hardware setup steps
	 that you don’t want to miss.

2. Install software. 
	 Visit bantam.tools/ndsoft for the latest downloads and instructions

3. Section “3. Quick start: Making your first plot”, starting on page 28.
	 Follow along with this section, which walks you through the
	 steps of making your first plot with the NextDraw.

4. Contacts & resources: Here, and again on the last page of the guide.

	 If you get stuck or need advice at any point,
	 please don’t hesitate to reach out for help!

	 Contact resources:  	 bantam.tools/ndcontact
	  
	 Our live support chat: 	 bantam.tools/chat

	 Online documentation and resources: bantam.tools/nddocs

http://bantam.tools/ndsoft
http://bantam.tools/ndcontact
http://bantam.tools/chat
http://bantam.tools/nddocs
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0.2 Welcome to NextDraw!

This is the user guide for the NextDraw family of drawing machines.  This 
guide is here to help you get started. It covers how you set up and use the 
machine, tips for operation, details about the software, and pointers to addi-
tional resources.

This guide covers operation of the following standard NextDraw models:
• Bantam Tools NextDraw 8511
• Bantam Tools NextDraw 1117
• Bantam Tools NextDraw 2234

Additionally, the sections of this guide covering everything except the physical 
setup of the machine and automatic homing, are applicable to AxiDraw brand 
machines produced by Evil Mad Scientist, if they have been updated to cur-
rent firmware, when using Bantam Tools NextDraw™ software.

0.3 This guide is updated from time to time.

Both this guide, and the NextDraw software are updated from time to time. 
We encourage you to check back occasionally for the latest version of this 
manual, and to check that you have the latest version of the software. You 
can also use the Configuration tab of the Bantam Tools NextDraw software 
to check online for available updates.

You can download the latest version of this guide at bantam.tools/ndguide

Look at the front cover of the guide to find the date and version number of 
the guide that you are looking at.

0.4 Copyright notice

Software and manual:  © 2025 Windell H. Oskay, Bantam Tools

http://bantam.tools/ndguide
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1. Introduction, unboxing, and setup

1.1 Introducing the Bantam Tools NextDraw™
The Bantam Tools NextDraw™ is the proven and reliable computer-controlled 
plotter that provides versatile solutions to artists, innovators, educators and 
handwriting enthusiasts.

The drawing head extends beyond the body of the machine, making it possi-
ble to also draw on flat objects bigger than the machine itself. For example, 
you can set it right on top of a box to write an address or add decorations. 
You can even set it on top of a poster board, chalkboard, or whiteboard to 
draw graphics in place.

The pen holder fits a wide variety of pens, including Sharpie fine and ultra-fine 
point markers, most rollerball and fountain pens, whiteboard markers, and so 
forth. It can even hold a fountain pen at a proper angle of 45° to the paper. 
You can also use implements that aren’t pens, such as pencils, chalk, char-
coal, brushes, and many others.

As an added bonus, the brushless pen-lift mechanism empowers users to 
use writing implements that need pressure on the paper, including traditional 
ball-point pens.

The Bantam Tools NextDraw™ is a hardware and software ecosystem de-
signed for a range of innovative applications not limited to drawing and hand-
writing. The ecosystem features a variety of accessories available to expand 
your capabilities and help you explore your creative frontier.
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1.2 Unboxing NextDraw

The Bantam Tools NextDraw ships in a box with foam padding that cradles it 
during shipping. The box also includes an accessory bag with power supply, 
USB cable, the pen clip, spring kit, and some basic tools for maintenance.

The NextDraw 8511 and NextDraw 1117 ship fully assembled and ready to 
use.  Lift these models out of their cradling foam, taking care to lift by the base 
only, and not by the flexible cable guides.

The NextDraw 2234 ships slightly disassembled to fit in a (yes very large but) 
reasonably sized box, and requires some re-assembly. If you have just re-
ceived a new NextDraw 2234, please see its re-assembly guide to get started.
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1.3 Included parts and accessories
Here are the parts that come with NextDraw:
 
1. The Bantam Tools NextDraw itself
2. Universal-input plug-in power supply, 9 V DC 2.5 A (US or multi-plug)
3. USB cable, A to Micro-B
4. Hex drivers and wrenches

Sizes include 2 mm, 2.5 mm, and 3 mm hex drivers, and low-profile 
8 mm and 10 mm wrenches. Of these, only the smallest (2 mm) hex 
driver is used in everyday operation.

5. Pen clip
6. Spring kit

To learn more about available NextDraw accessories, please visit: 
	 bantam.tools/ndacc

2. Power supply

3. USB Cable

1. NextDraw

4. Hex drivers
and wrenches

5. Pen clip

6. Spring kit

http://bantam.tools/ndacc
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1.4 Bantam Tools NextDraw anatomy
Let us look at the parts and features of the NextDraw. We will refer to these 
parts by name throughout this guide. The details and appearances of some 
of these parts vary between models, for example the base of the NextDraw 
8511 is a silver-colored aluminum extrusion, while the NextDraw 1117 and 
2234 have bases made from black-colored billet aluminum.

Pen holder

Base; Central strut

Extended feet

Base; Central strut

Left motor & electronics cover

Right motor
& cover

Cable Guides
(Not handles!)

Main Carriage (“X carriage”)

Pen holder

Top View

Y Carriage

Timing (drive) belt
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Detail: Left side of base 

Power
Jack

Electronics 
Cover

Stepper motor
Pause Button

Reset button
(recessed)

USB Port

Power switchPower indicator light

Cable keeper

Home 
Position
Label
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Detail: Pen holder

Brushless
Pen-lift servo motor

Vertical slide

Lift arm

Thumbscrew

Pen Clip

M3 Pen Clip
Screws

Vertical shafts

Y Carriage

§1.4 Bantam Tools NextDraw anatomy, continued.
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1.5 Safe handling of the NextDraw

1). Lifting: Lift NextDraw by the central strut of the base only. Do not lift by 
the cables, cable guides, carriages, or pen holder. 

The NextDraw 1117 has a handle milled into the back of the central strut, to 
provide an easy well-defined lifting point in the middle of the machine.

The NextDraw 2234 should be lifted with two hands to support it. There are 
handles milled into the back of the central strut, close to the two ends.

2). Heat:  The motors at the two ends of the base may get warm. This is nor-
mal, but it is helpful to be aware of it. They should not get too hot to touch.

3). Moving parts: NextDraw has exposed moving parts. Keep fingers, hair, 
and other things that could get caught, crushed, or tangled safely away from 
the belt and the pinch points between the moving carriage, the pen holder, 
and the motor covers.

Warning: Keep fingers away from pinch
points while NextDraw is operating.
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1.6 Attach the pen clip
The first setup step is to attach the pen clip, which is removed for shipping.

Thread the thumbscrew into the pen clip. Use the two M3 screws to attach 
the pen clip to the front face of the vertical slide, using the long 2 mm hex 
L-wrench (the smallest of the included L-wrenches).
 
For ease of adjustment, we recommend that you orient the pen clip as shown 
here, with its “open” side to the left.

2 mm ball-end
hex L-wrench

Thumbscrew

Front face of 
Vertical slide

Pen clip

M3 Screws (2)
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1.7 Pen clip orientation
The pen clip can be attached in two different orientations: Vertical, which 
points the pen straight down, or diagonal, which holds the pen at a 45° angle 
to the paper. Which to use mostly depends on what type of pen you are using.

To switch between the orientations, loosen (but do not remove) the two small 
screws. Lift the pen clip slightly, then rotate it to the other position. Lower it 
back down and tighten the two screws back into place.

The vertical pen position (A) is generally the best choice for technical pens, 
pens that require pressure, such as ball-point pens (C), or multi-color plots. 

The diagonal position (B) is generally the best choice with fountain pens (D) or 
other pens that write better at an angle. 

C D

A B
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1.8 USB, Power, and Cable management
The NextDraw needs power to operate and connects to your computer by 
USB. Here, we connect the two cables and secure them with the cable keeper.

1.8.1 About the power supply
The plug-in power adapter included with the NextDraw (9 V dc, regulated, 
center positive) works with worldwide mains power (100-240 V ac). Do not 
plug the power supply into any kind of voltage-converting power adapter.

The power supply comes in two versions, one with a North American style 
power plug, and an International multi-plug version available at
https://bantam.tools/9vint .

1.8.2 About the USB cable
All Bantam Tools NextDraw models currently ship with a USB A to Micro-B 
cable. You can switch this out for other types of high-quality USB micro cables 
(e.g., USB C to Micro-B) as needed. 

If your computer uses USB C, we recommend using a direct USB C to  Micro-B 
cable ( https://bantam.tools/ucmb ) rather than an adapter.

WARNING: Use only the original, supplied plug-in power 
supply. If you are unable to identify which power supply is 
the original, please contact technical support. If your power 
supply needs to be replaced, use only the original type.

https://bantam.tools/9vint
https://bantam.tools/ucmb
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1.8.3 Connect Cables and the Cable Keeper

Plug in the power and USB cables. 

Then, remove the Cable Keeper, a black plastic clip held in place by a thumb-
screw.  Removing the Cable Keeper exposes the Wiring Channel, on the top 
of the left motor & electronics cover.

Remove Cable Keeper
& thumbscrew

Plug in 
Power

Notice Wiring Channel

Plug in USB
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Using the Cable Keeper like this keeps your desk neat by pointing the cables 
backwards, and provides important strain relief that prolongs the life of your 
cables and electronics.

§1.8.3 Connect Cables and the Cable Keeper, continued.

Guide the two cables back and into the Wiring Channel, and then place the 
Cable Keeper over the cables.  Use the thumbscrew to secure the Cable 
Keeper in place.
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2. Initial Software Setup
2.1 Install the software

You will need to install software on your computer to operate the NextDraw. 

Please start at: 	 bantam.tools/ndsoft .

Starting there, please follow the directions specific for your operating system:
• For Mac and Windows, there are easy installers that you can download.
• For Linux, one or more manual steps are required.

The software that you will install consists of two main parts: Inkscape, the 
superb (and free) drawing program, and a set of plugins, or extensions that 
directly operate the NextDraw from within Inkscape.
 
If you run into any difficulty while following along with the installation steps, 
please contact us for support —we are here to help. You can find our contact 
information on the last page of this user guide.

http://bantam.tools/ndsoft
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2.2 Opening Inkscape for the first time
Once you have installed the software, open Inkscape. 

If this is the first time that you open Inkscape, you may be greeted by several 
“first-time setup” screens. The exact appearance of these screens will vary 
between Inkscape versions. 

Optionally, select light or 
dark theme for Inkscape.

Click here to go to 
last setup screen.
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You can use the last of the setup screens to create a new document from 
several different page-size templates. 

However, we generally recommend to uncheck the “Show this every time” 
box, so that you don’t see these screens again past the first time opening 
Inkscape.

Optional but recommended: Uncheck 
this box so that these “first-time setup” 
screens aren’t shown every time that 
you open Inkscape.

Click here to close this screen 
and continue.
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2.3 The Bantam Tools extensions
Once you have Inkscape open and are past any “first-time setup” screens, the 
NextDraw software, if properly installed, can be found within the Extensions 
menu of Inkscape.

There are two relevant items in the Extensions menu: Bantam Tools Next-
Draw™, the primary software interface to NextDraw, and the Bantam Tools 
Utilities submenu, which contains several supplemental tools.

Later in this user guide, we will go into depth about the different features of 
the software and how to use it.
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2.4 Select your model
The most important software configuration step is to select which model of 
plotter you are using.  Open Bantam Tools NextDraw from the Extensions 
menu of Inkscape.

With the panel open, click to select the Options > Configuration tab:
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§2.4 Select your model, continued.

Then, select which model of plotter you are using from the Model drop-down 
menu:

The list of models supported by the software includes the different sizes of 
Bantam Tools NextDraw, as well as AxiDraw machines manufactured by Evil 
Mad Scientist.

If you are using an AxiDraw machine that has been upgraded with a brushless 
pen-lift motor, also select “Brushless upgrade” from the Pen-lift motor drop-
down menu.



27

2.5 Aside: Alternative software, CLI, and APIs

The Bantam Tools NextDraw software is available in two alternate ver-
sions that may be helpful for developers or for anyone who would to 
control the machine programatically rather than through Inkscape. 
Additionally, there is a low-level serial control protocol available that can 
be used to control the machine outside of the NextDraw software.

2.5.1 Bantam Tools NextDraw CLI API

The Bantam Tools NextDraw command-line interface (CLI) is proven, re-
liable, and feature-rich control software that can be used on its own or 
integrated with almost any other system.  It offers essentially the full set 
of features otherwise available through Inkscape. However, as a com-
mand-line utility, it can be used on its own or from within almost any 
scripting or programming environment.

You can learn more about it at:  https://bantam.tools/nd_cli

2.5.2 Bantam Tools NextDraw Python API

The Bantam Tools NextDraw Python API is proven, reliable, and fea-
ture-rich control software that can be used within your own Python 
scripts. It offers essentially the full set of features available through Ink-
scape, and allows you to call and operate those features from within your 
own Python scripts. 

In addition to the core functionality of plotting SVG files, the Python API 
also provides an “interactive” context for sending individual motion com-
mands including “Goto XY” type movements.

You can learn more about it at:  https://bantam.tools/nd_py

2.5.3 Low-level “EBB” command protocol

If you would like to directly interface to the NextDraw’s EBB motor control 
board, it has a serial command protocol that you can control from any 
programming interface that can address your USB port.

For more information, please see the documentation links on our wiki 
site: http://bantam.tools/nddocs

https://bantam.tools/nd_cli 
https://bantam.tools/nd_py
http://bantam.tools/nddocs
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3. Quick start: Making your first plot
In this section, we will briefly walk through the steps to make your first plot. After 
this section, we will discuss each part of this process in additional depth.

3.1 Pen and paper
For your first plot, you’ll need a pen (or something else to write with) and pa-
per (or something else to write on). 

The easiest way to fix paper in place is to use one of the magnetic easel acces-
sories, (Letter/A4: bantam.tools/mea4 , Tabloid/A3: bantam.tools/mea3 ) a 
painted and textured sheet of heavy steel with magnets to hold down paper. 

However, just about any way to hold paper can work. You can use a clipboard, 
a magnetic table with magnets, or tape to hold down paper.

http://bantam.tools/mea4
http://bantam.tools/mea3
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3.2 Automatic and Manual Homing
In most cases it is necessary to move the carriage to the Home Corner prior 
to beginning a plot. This is where the carriage is as far left and as far back as it 
can go: where the pen holder is closest to the engraved label “Home”. 

When a plot finishes, the NextDraw will return to the Home Corner automat-
ically, leaving it ready for your next plot.

3.2.1 Automatic Homing
Bantam Tools NextDraw drawing machines have an automatic homing fea-
ture which is enabled by default. The option to control it can be found on the 
Options > Advanced tab of the Bantam Tools NextDraw software.

If the Enable automatic homing option is checked, the NextDraw will per-
form an automatic home-finding sequence before starting a plot, automat-
ically moving to the Home corner, if it is not already homed. The sequence 
and directions of movements to locate this position may be counterintuitive 
in some cases. 
 
The Homing sequence is also started automatically if you use the Walk Car-
riage utility commands (§6.13.1 Walk Carriage commands, on page 88) be-
fore the carriage is not homed. 

Homing will be performed again when power is lost or when switching be-
tween plotting modes that require switching motor configurations. 

When automatic homing is disabled — or on legacy AxiDraw machines that 
do not support automatic homing — it is necessary to follow the guidance 
from the next section on manual homing.
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3.2.2 Manual Homing
When automatic homing is disabled — or on machines that do not support 
automatic homing — it is necessary to move the carriage to the Home Corner 
by hand before starting a plot. 

The carriage should only be moved when the power to the motors is off. If it 
does not move easily, turn off the motors so that you are not trying to force 
them. 

 To turn off the motors, select from the Extensions menu in Inkscape: 
       Extensions > Bantam Tools Utilities > Disable XY Motors

Alternately, you can use the Raise pen, turn off motors command in the 
Setup tab of the Bantam Tools NextDraw software. 

You can also switch off the power, using the main power switch, in order to 
release the motors and move the carriage. (The power switch is present on 
Bantam Tools NextDraw machines and  AxiDraw machines with the brushless 
upgrade.)

Home
Position
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Once motor power is off, slide the carriage to the Home Corner by hand. 
Move it by holding onto the solid block of metal behind the vertical slide of 
the pen holder. 

Do not push the vertical slide of the pen holder or pen directly.

3.2.3 Aside: Home position with manual homing
When automatic homing is not active, the position where the motors are 
first energized is said to be the plot origin.  That position will be record-
ed and maintained as the “effective home” position for the plot, even if it 
is not at the machine’s Home corner.  (This provides an effective means 
to start plots at positions other than at the true Home position.)

If a plot in progress is stopped such that the motors are still energized 
but the carriage was not returned to its plot origin, the machine will re-
member its position offset from the plot origin. So long as the motors 
have stayed energized, any new plot started will be positioned with re-
spect to the same plot origin position. 

The Walk Carriage utility commands (page 88) can be used to offset 
the position from where  the motors are first energized. The carriage 
position when you begin a plot will be recorded and maintained as the 
plot origin.
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3.3 Check pen-up and pen-down positions
Within Inkscape, open the Bantam Tools NextDraw software:
	  Extensions > Bantam Tools NextDraw 

In the Setup tab, select the Cycle pen down then up action:

Then, click Apply. If the power is on and everything is set up correctly, the pen 
lift motor should lower to its pen-down position, wait just a moment, and then 
lift to the pen-up position. It will do so again each time that you press Apply. 
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3.4 Insert your pen
Starting with the NextDraw at the pen-up position, insert your pen into the 
pen clip, just above the paper, and tighten it in place with the thumbscrew. 

Whether your pen is oriented vertically or diagonally, the height of your pen 
tip should end up approximately 1/8 to 1/4 inch (3 - 6 mm) above the surface 
of the paper. 

Take care to only apply gentle force 
with the thumbscrew; do not tight-
en it more than necessary.

Pen-up height: 
1/8 - 1/4 inch (3-6 mm)

above paper
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3.5 Position your paper
With the carriage at the home corner, position the upper-left corner of your 
paper directly beneath the tip of your pen, such that if your pen were to be 
lowered, it would touch the corner of the paper closest to the Home corner. 
(Keep in mind that, depending on your setup, it may be preferable to move 
the NextDraw itself, rather than the paper.) 

Square the paper up so that its top edge is parallel to the base of the Next-
Draw.

The photos below shows the paper positioned correctly, with its corner di-
rectly under the tip of a pen – in these cases a ball-point pen, as well as a 
fountain pen mounted at 45° to the paper. 
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3.6 Open a document and print it
Download the set of NextDraw example files from: bantam.tools/ndex

The download is a small zip archive of example files. Open (unzip) the archive. 
Then, within Inkscape, open up the file called HelloWorld.svg. 

Once open, the document should look approximately like this in Inkscape:

If you cannot see the full page outline when you first open the file, select from 
the menu View > Zoom > Page, or type the number ‘5’ on your keyboard.

http://bantam.tools/ndex
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Finally, open Extensions > Bantam Tools NextDraw, switch to the Plot (first) 
tab, and click Apply to begin the plot.

The NextDraw should now begin printing your document, and will return 
back to the Home Corner, with pen up, when it finishes.

If you need to stop the plot for any reason, press the Pause button on the 
left side of the machine.  (See “1.4 Bantam Tools NextDraw anatomy” on page 
12.)

§3.6 Open a document and print it, continued.
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With a black pen, it will look something like the following:

3.7 Recap: Setting up a print
Let us summarize the steps that we’ve been over:

1) If automatic homing is not enabled, move carriage to the Home Corner.  
2) Use the Setup tab to Cycle the pen down then up. 
3) Clip in your pen, with height just above the paper. 
4) Position your paper with its upper-left corner below the pen tip. 
5) Use the Plot tab in NextDraw Control to plot the document.

The next few sections of this guide cover these same topics in greater detail.
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4. Workholding
Whatever workpiece you wish to write or draw upon – whether that is paper, 
boxes, wood, cloth, or cookies – needs to be held such that it does not shift 
while plotting. 

4.1 Printing on large workpieces 

For large items such as the poster board and box shown here, the Bantam 
Tools NextDraw may be placed directly on top of the workpiece.  Other exam-
ples of large workpieces that NextDraw can sit upon might include things like 
shipping boxes, fabric, wooden surfaces, chalkboards or whiteboards.

Position the NextDraw such that the pen tip is at the upper left corner of the 
area that you intend to plot upon. The software will treat the corner of the 
page in your Inkscape document as Home Corner for the purpose of plotting.



39

4.2 Printing on small workpieces
Common solutions to hold smaller workpieces include clipboards, some-
times with rubber feet, tape, and magnets, in combination with a magnetic 
work surface. 

Bantam Tools also sells “magnetic easels” – textured steel boards with rul-
ers and magnets – are available as optional accessories for NextDraw in two 
different sizes:  Letter/A4: bantam.tools/mea4 , Tabloid/A3: bantam.tools/
mea3 . 

Most of our usage examples are made with the magnetic easels, in part be-
cause they make the paper position easy to see in photographs.

http://bantam.tools/mea4
http://bantam.tools/mea3
http://bantam.tools/mea3
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4.3 Document orientation
4.3.1 The shape of the travel area
The “travel” or “print area” of the NextDraw is wider than it is tall.  

For example, on the Bantam Tools NextDraw 8511, the travel area is about 
11.8 x 8.5 inches (30 x 21.6 cm). A full page (letter or A4) can fit in the printable 
area, but only if it is wider than it is tall.

Travel area: 11.8 (wide) x 8.5 inch

Document
8.5 wide x 11 inch

Document does not
fit vertically like this!

This document does fit 
easily when rotated.
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4.3.2 The Auto-rotate feature

If your document is wider than it is tall (or square), it is said to be in landscape 
orientation, it will print in its original orientation. The envelope above is a 
good example of a document that is wider than it is tall.

However, If your document is taller than it is wide, it has portrait orientation; 
and will normally print “sideways” as in the lower example above.

This Auto-rotate feature makes it so that you can work with tall documents, 
print things the full size of the travel area, and not have to rotate the docu-
ment on your screen.  

Whether vertical or horizontal, rotated or not, it is always the corner of the 
paper closest to the Home Corner that one aligns below the tip of the pen.  
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4.3.3 Enabing or disabling Auto-rotate
The Auto-rotate feature is controlled by a checkbox in the Bantam Tools
NextDraw software, located on the Options > Advanced tab.

The option is enabled by default. 

If you uncheck the box to disable automatic rotation, files will only print in the 
same orientation as they appear in your document.
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5. Pens and the pen holder
5.1 About the pen holder
The pen clip included with the NextDraw fits pens up to ⅝ inch (16 mm) in 
diameter. Other types of pen holders and mounts are available as optional 
accessories.

The maximum recommended pen weight for standard applications is 1.6 oz 
(45 g). When using heavier implements, reduce acceleration and consider fas-
tening the extended feet of the NextDraw to your table with clamps, weights, 
or screws to prevent excess motion and to prevent the machine from tipping 
forward.

The design is such that the pen rests on the surface by its own weight. That 
allows it to ride over surfaces that are textured or otherwise uneven, however 
it also means that the pen holder does not apply much if any downward pres-
sure. In cases where downward pressure is helpful, you can use the Spring 
Kit, included with the NextDraw, to apply pressure.

5.2 Pen choices
Good choices for pens include fountain pens, permanent markers, rollerball 
pens, technical pens, (small-bodied) whiteboard markers, liquid chalk mark-
ers, and other writing and drawing instruments that do not require significant 
pressure. 

While we refer to writing and drawing instruments as “pens” to be concise, 
other instruments such as automatic pencils, chalk, charcoal, and brushes 
can also work well in many cases. Others, like traditional ball point pens, may 
work poorly unless you apply pressure with the Spring Kit.

Aside: Fragile or delicate pens: If you choose to use fragile pens (such as 
high-end fountain pens with celluloid barrels), exercise great care when 
inserting the pen. You may wish to wrap the barrel in a thin, soft cloth 
to avoid scratching, and use little or no pressure from the thumbscrew. 
Moderately priced fountain pens, like the Lamy Safari or the Pilot Metro, 
tend to be quite tough, and require little special treatment.
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5.3 Adjusting pen heights
The pen-up and pen-down heights are configured in the Setup tab of the 
Bantam Tools NextDraw software.  Both values can each be adjusted be-
tween 0 and 100% to suit your needs. Higher percentage values lift the pen 
higher.

Once you have some experience with the process, the “pen” part of getting 
ready to plot is described by two quick steps:

1) Cycle the pen holder to the pen-up position.
2) Insert your pen, just above the paper.

You may find it helpful, when inserting the pen, to rest the its tip on a consis-
tent spacer such as a thin bottle cap or a stack of a few coins. 

The default pen heights of 60% (up) and 30% (down) are a good starting point. 
When changing either value, cycle the pen down and up to physically move 
the pen holder to the new positions.

Tip 1: With a consistent pen height, if you find that the pen is not touching 
down everywhere that it needs to, use a lower pen-down position. If you 
find that the pen is not lifting everywhere it needs to, raise the pen-up 
position.

Tip 2: When cycling the pen to try new heights, you can protect the paper 
that you will be writing upon with another sheet of paper, to avoid writing 
on your actual workpiece.
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5.4 The Spring Kit
The Bantam Tools NextDraw includes a Spring Kit that can optionally be used 
to increase speed and to add downward pressure for writing.

5.4.1. Working without the Spring Kit
Normally and by default, the pen-lift stage of the Bantam Tools NextDraw 
rests a pen on the writing surface essentially by gravity alone, lifting it off the 
page before and after each path drawn. 

This works well in most circumstances, especially when working with foun-
tain pens, markers, or liquid-ink rollerball pens, all of which write well without 
added pressure.

One possible issue that you may encounter is that the lift arm of the brush-
less pen-lift servo on the NextDraw can lower the pen faster than gravity 
alone. Without adding a spring to keep the vertical slide in contact with the 
lift arm, the pen can bounce off the paper, and bounce when raised as well. 
This can, at the fastest pen lifting and lowering speeds, lead to plot defects 
and excess noise.

5.4.2. About the Spring Kit
When installed, the Spring Kit presses the pen down towards the page while 
writing. That’s helpful for working with certain types of writing implements, 
such as traditional ball-point pens, which require downward pressure. 

It also helps the pen to raise and lower faster by keeping the vertical slide in 
contact with the lift arm.

Downward pressure can increase the overall amount noise when using the 
machine — since a pen can potentially make a lot of noise when it hits paper 
hard. 
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WARNING: Carefully read and follow these instructions 
when using the Spring Kit to avoid potential damage to 
your pen-lift motor and/or vertical pen-lift stage.

Shaft Collar

Spring Backer

Light
Spring

Heavy
Spring

5.4.3. Parts in the Spring Kit
There are four parts to the Spring Kit: A Shaft Collar, a Light Spring, a Heavy 
Spring, and a machined plastic piece called the Spring Backer.

Springs wear out over time; replacements are available from Bantam Tools.

Downward pressure can also damage or destroy, and is thus generally not 
recommended for, delicate pens such as fountain pens or technical pens, 
and it can cause rapid wear on fiber-tip pens.

Using the spring kit reduces the available vertical travel range, as the spring 
does take up some part of that range.  The critical part of what follows will be 
setting the pen-up height correctly with a spring in place.
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5.4.4. Initial setup for Spring Kit

In the Setup tab, set the pen-up height to 50%, and pen-down to 0%.

Then, in the Utility tab, select the Toggle 
the Pen up/down command. 

Click Apply to toggle the vertical slide up 
and down until you are sure that it is in 
the “pen down” position.
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5.4.5. Add the Spring Backer
The spring backer has one smooth side and one side with a ridge on it.

With the vertical slide in the “pen down” state and the pen-up/pen-down po-
sitions still set to 50% and 0%, place the spring backer over the shaft that 
extends above the vertical slide. 

Orient the backer smooth-side down, with the ridge on the top.
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Light
spring

Heavy
spring

5.4.6. Add the Spring
Place a spring, either the light or heavy one, over the shaft and spring backer. 
The light spring sits inside the raised ridge on the spring backer and the heavy 
spring sits around it.

The heavy spring gives about twice the force of the light spring, and works 
well for pens that require substantial force, such as traditional ballpoint pens.

The light spring does not add as much pressure; just  a little bit. But that can 
make a substantial difference when working with gel pens and other types 
that benefit from a small amount of pressure.

If you’re just getting started, either spring is a reasonable choice.  You can 
always switch later if you want less or more downforce.
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5.4.7. Add the Shaft Collar
Slip the Shaft Collar over the end of the shaft until its top is flush with the top 
of the shaft.  (If there is a gap between the bottom of the Shaft Collar and the 
top of the spring, it’s OK to lower the Shaft Collar to the top of the spring.)

Tighten it firmly in place with your 2 mm hex L-wrench (the same one used to 
adjust the pen clip). Ideally, use the long end to start it, and the short end of 
the wrench to tighten it well.
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5.4.8. Test the safe range of motion
The safe range of motion for the vertical slide is from the bottom of travel 
until the spring is almost compressed to a solid. The spring must not become 
fully compressed to a solid or it can potentially damage the servo and slide. 
See the pictures below for reference.

Go back to the Setup tab and toggle the pen up– and be ready to toggle it 
right back down again if necessary.  

With the pen raised, make sure that the spring is not compressed all the way 
to a solid.

If the spring is compressed to a solid, toggle the pen back down immediately. 
Then, select a lower pen-up position and try again.

If the spring is not compressed to a solid, then you can adjust the pen-up po-
sition higher, so long as it does not become solid.  Once your pen-up position 
is set, then choose your pen-down position to give an appropriate range of 
vertical motion for your application. A starting range of about 30 is typical.

Spring compressed to a 
solid in the pen-up posi-
tion.

Avoid this situation; it can 
damage the motor and 
slide.

Acceptable pen-up posi-
tion, with spring not com-
pressed to a solid.
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6. The Bantam Tools NextDraw extension
In this section we will introduce the features and options of the Bantam Tools 
NextDraw extension for Inkscape, the primary interface to the NextDraw. It 
can be found within your Inkscape menu at
	 Extensions > Bantam Tools NextDraw™...

The software has a tabbed interface, where the different tabs contain differ-
ent settings or control different functions.

One option, Preview mode, is available in every tab. It can be enabled by 
checking the box. When checked, Preview mode simulates plotting only, let-
ting you see how your document will plot. You can read more about preview 
mode in §6.8 Preview mode, on page 72
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6.1 Plotting the document
The Plot tab is used to plot the document on the NextDraw.

There are two options on the Plot tab: Content selection and Layer number.

To plot the entire document, select Plot entire document from the Content 
selection drop-down menu, and then press Apply.

This will plot the entire document, including all visible layers. You can select 
which parts of a document will plot by hiding and showing different parts of 
the file, or by using Layer-based features as we will discuss in section §6.3 
Working with multiple layers and colors, on page 58.

6.2 Pausing, resuming, and canceling plots

6.2.1 The pause button
To stop a plot in progress, press the pause button: the large white button 
on the left-hand side of the NextDraw. (See the pictures on page 13.) The 
NextDraw will raise the pen and stop moving once the queued set of motion 
commands has exhausted.

Note: You must physically press the pause button to stop a plot in progress. 
(Inkscape has a “Cancel” button, but it does not stop running extensions.)

Once paused, you can make adjustments in the settings (for example, to the 
pen height or plotting speed), before resuming, if you choose to do so.

Certain settings that affect plot order, such as hidden line removal and plot 
optimization cannot be changed between pausing and resuming a plot.
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6.2.2 To resume a plot after pausing
To resume a plot after pausing, select the Resume tab and click Apply.  

Plot progress is stored in the SVG file, so if you plan to quit Inkscape and re-
sume later, save the document first.
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6.2.3 Canceling a paused plot
No explicit action is needed to cancel a plot that was paused in progress.

If power to the machine has not been maintained and automatic homing is 
disabled, be sure to move the carriage to the Home position before starting 
another plot.

When an SVG document has plot progress data in the file, indicating that a 
plot was previously paused, and you try to start a new plot from the Plot tab, 
(rather than resuming with the Resume tab), you may instead get a warning 
message:

This message is intended to prevent the occasional accident where one starts 
a plot over from the beginning, rather than resuming it.

If you do intend to start a new plot, press Apply again to override the warning 
and start the plot.
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6.3 Working with multiple layers and colors
By default, the Bantam Tools NextDraw software will print all visible paths in 
your document. A document can, at your option, be organized into multiple 
Layers. 

When you use the Plot tab to print a full document that contains multiple lay-
ers, each visible layer will print, and the order of printing is from lowest layer 
first to highest layer last. 

You can also use the Plot tab to plot a single layer, or some specific set of 
layers. These methods are particularly useful for organizing and plotting doc-
uments that require multiple pens or colors.

6.3.1 Inkscape’s Layer menu
To create layers and move objects 
between them, use the commands in 
Inkscape’s Layer menu.

The commands in this menu let you 
add, remove, and re-arrange layers 
as you see fit.

You can also use the “Move Selection” 
commands in this menu to move se-
lected objects between layers.

To see a list of the layers in the doc-
ument, as well as to see which lay-
er the selected object is in, you can 
open the Layers and Objects panel 
by selecting it from this menu:

Layer > Layers and Objects...
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6.3.2 The Layers and Objects panel

The Layers and Objects panel lists layers 
in the document and the objects within 
those layers. You may wish, as we have 
done here, to select the option to only 
show the layers, not objects within them.

Within this panel, you can add, remove, 
re-order, rename, hide, show, and lock 
layers. 

The document shown here, one of the NextDraw example files, has 6 layers 
with different names. (We have also hidden one layer and locked one layer to 
show what that looks like.)

The “eye” symbols to the right of the some layer names indicate if layers are 
visible. An “open eye” (or no eye) indicates that the layer is visible.  A “closed 
eye” symbol indicates that a layer is hidden. Click the eye to show or hide an 
individual layer. Hidden layers and objects will not be printed; Hiding layers is 
an effective way to plot only certain parts of a document.

The “lock” symbols to the right of the eye symbols indicate if a layer is locked. 
A locked symbol (closed padlock) indicates that the layer is locked and cannot 
be changed. You can click the lock symbol to lock or unlock a layer.

Locked layer

Unlocked 
layer

Move or 
delete layer

Hidden layer

Layer 
settings

Create new layer

List of
layers
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6.3.3 Selecting layers to print by number

In addition to hiding and showing layers, you can select which visible layers to 
plot, directly within the Plot tab. To do so, select Plot selected layers from 
the Content selection drop-down menu, enter the Layer number to select 
and press Apply.

When you start a plot this way, the NextDraw will only plot layers with names 
that begin with the number entered in the Layer number field. Give layers 
that you wish to print this way names that begin with an integer in the range 
0 through 1000. 

After plotting one or more layers by Layer number, you can change any set-
tings that you wish to, or switch to a different pen, and then plot other layers 
with a different Layer number selection. This makes it possible to plot por-
tions of a document with different colors and (e.g.,) speeds.

Only “top-level” layers, not sublayers or other named groups, can be selected 
for plotting by Layer number.
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Example 1: Suppose that a document has three layers with the names,
1 - Red circles
2 - Blue squares
2 - Blue waves

You could put a red pen in the NextDraw, and then plot the “1 - Red circles” 
layer alone by entering 1 as the Layer number and pressing Apply. You can 
then change to a blue pen, enter 2 as the Layer number, and press Apply to 
print both of the “Blue” layers.

Example 2: Example file, multicolor_layers.svg

This is the same file that we 
looked at previously, in the con-
text of the Layers and Objects 
panel.

This file has two layers that start 
with the number 1 (and thus 
would print together if selected 
by Layer number), and four ad-
ditional layers that are set up to  
print separately, with different 
pens. 

The rest of the layer name, af-
ter the number, can be used for 
any notes that you might have 
about the context or setup for 
those layers.
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6.3.4 Additional Layer Control features
Beyond selecting layers in the Plot tab, there are additional Layer Control 
commands and parameters that can be specified through the layer name. 

You can use properly formatted codes to specify the pen-down height and 
the speed for printing specific layers.  There are also special codes that can 
introduce a timed delay while plotting or force a programmatic pause (as 
though you had pressed the pause button to halt a plot). These types of 
codes are seldom added in everyday plotting, but can be useful in developing 
templates or workflows for specialized applications.

One additional, and particularly useful, feature is that any layer with a name 
starting with a percentage sign (%) is designated as a documentation layer, 
and will never be plotted.

The Layer Control features are always active, and (where applicable) take 
precedence over settings within the Bantam Tools NextDraw extension for 
Inkscape.  For example, they can be used to plot different layers at different 
speeds, even while the software setting only allows a single speed setting.

As with plotting by Layer number, Layer Control features only work on the 
names of “top-level” layers, and not sublayers.

The complete syntax for NextDraw Layer Control can found at:
		  bantam.tools/ndlc

http://bantam.tools/ndlc
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6.4 The Setup tab
We have already discussed, in §5.3 Adjusting pen heights, on page 44, us-
ing the Setup tab to set pen heights and cycle the pen.

The Setup tab has two further actions that it can perform, when selected: 
Perform automatic homing and Raise pen, turn off motors.

Select Perform automatic homing and click Apply to begin the automatic 
homing cycle to move the carriage Home. (It isn’t usually necessary to per-
form Homing with this option, but it is here in case you have a reason to do 
so outside of the usual context of starting a plot.)  Automatic homing is only 
available on supported plotter models, and only when Enable automatic 
homing is checked on the Options > Advanced tab. See §3.2.1 Automatic 
Homing, on page 29 for more information.

Select Raise pen, turn off motors and click Apply to raise the pen holder to 
its pen-up position and disable the XY stepper motors. This is a useful setup 
function for manual homing; see §3.2.2 Manual Homing, on page 30.
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6.5 Speed controls
The Options tab contains several panels that allow you to configure the be-
havior of the machine and how plots are processed.

The first of these, the Options > Speed tab, presents options that control 
the speed of the NextDraw. These include the speed limits and acceleration 
rates used for the horizontal (XY) carriage motion, as well as pen lifting and 
lowering rates.

The upper part of this panel has controls for Handling mode, Pen-down 
movement speed, Pen-up movement speed, and Acceleration. These op-
tions, together, control the rates of horizontal (XY) carriage motion.

Clicking the Apply button with the Speed tab selected has no effect; settings 
are saved automatically, and clicking Apply does not initiate a plot or perform 
any other function.
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6.5.1 Handling modes

The Handling mode drop down menu allows you to select one of four gen-
eral Handling modes: Technical drawing, Handwriting, Sketching, or Con-
stant speed. These names are descriptive, but you may find that one or a 
different handing mode works best for you and your actual usage.

The choice of Handling mode controls the overall scales of precision, speed 
and acceleration.  For example, “100%” speed in Sketching is faster than 
“100% speed” in Handwriting, and Maximum acceleration in Handwriting is 
higher than Maximum acceleration in Sketching.

The default Handling mode, Technical drawing, uses a moderate top speed, 
medium-high Maximum acceleration, and high precision.  It is a good starting 
point for many applications, including handwriting-like work in cases where 
precision is more important than speed.

The Handwriting Handling mode has moderate top speed, very high Maxi-
mum acceleration, fast pen-up speeds, and relatively low precision. For hand-
writing-like work where acceleration on tiny strokes and curves is much more 
important than the top speed that can be achieved, the Handwriting Han-
dling mode can give a significant reduction in total plot time.

The Sketching handling mode has a high top speed, moderate Maximum 
acceleration, fast pen-up speeds, and moderate precision. For artwork con-
sisting of long strokes, where the top speed is more important than acceler-
ation on small strokes, the Sketching Handling mode can give a significant 
reduction in total plot time.

The Constant speed handling mode disables acceleration and moves the 
pen at a constant speed when it is down. It has a relatively low top speed, 
“instantaneous” acceleration, and high (theoretical) precision. In practice, mo-
tion artifacts from taking corners without slowing down make it less precise 
than the Technical drawing Handling mode except at low speeds. The Con-
stant speed Handling mode is most useful for specialized applications where 
moving at a constant speed is a priority. The constant speed motion applied 
by this mode applies only when the pen is down; Acceleration is used during 
pen-up travel.
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6.5.2 Pen-up and pen-down movement speeds

The Pen-down movement speed and Pen-up movement speed parame-
ters allow you to select what maximum speed will be used with the pen down 
(for writing or drawing) or pen up (for moving between paths). 

Both values are given as percentages (1-100%), and give percentages of the 
“top speed” available in the selected Handling mode.

In all cases except the Constant speed Handling mode, these two speed 
settings control speed limits: The maximum speeds that can be developed, 
given sufficient distance to accelerate. These speed limits may or may not be 
reached in a given distance, depending on the Acceleration setting.

When Constant speed Handling mode is selected, the speed of travel when 
the pen is down is controlled directly by Pen-down movement speed. 

6.5.3 Acceleration

The Acceleration setting controls how quickly the pen will approach the 
speed limits set by the Handling mode in combination with the Pen-down 
movement speed and Pen-up movement speed values. Acceleration is at 
least as important as the speed limits in determining the total time that a plot 
will take. Slower acceleration values tend to give smoother movement and 
neater curves at the cost of longer plot times.

There are four values available to select from a drop-down menu, Standard, 
Maximum, High, and Slow.  The default value, Standard, is a moderate val-
ue between High and Slow.
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6.5.4 Pen raising and lowering speeds
The Pen raising speed and Pen lowering speed parameters control the 
vertical motion speed between the heights set in the Setup tab (page 44). 
The pen raising and lowering speeds can each be selected from a drop-down 
menu, with options Maximum, Standard, Slow, Very slow, and Dead slow.

The NextDraw pauses horizontal motion while raising or lowering the pen, 
until that motion is complete. These pauses prevent it machine from mak-
ing pen-up movements until the pen is actually clear of the paper, and also 
prevent pen-down movements from beginning until the pen is touching the 
paper.  

If you are trying to increase the speed of your plots, be aware that the to-
tal vertical travel distance is an important factor in how long pen lifting and 
lowering takes. Thus, try to decrease the vertical range first, and look at the 
speeds next.  Slower lifting (and especially) lowering can potentially lead to 
neater writing and prolong the life of the pen-lift motor as well as your pen 
tip.
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6.6 Printing multiple copies

The Options > Copies tab lets you print multiple copies of the same docu-
ment with an optional time delay between copies.  If Copies to Plot is any 
value other than 1, then after the first copy finishes, the next copy will auto-
matically begin after a time delay in seconds given by Page Delay. 

For example, to plot 3 copies with 15 
seconds delay between each, enter 3 
for Copies to Plot and 15 for the Page 
Delay.

As a special feature, if Copies to Plot is set to 0, pages will plot continuously 
— separated by the given Page Delay — until the Pause button is pressed. 
This is a great feature for repeating tasks, such as using the NextDraw as a 
signature machine to sign a whole stack of pages. 

The Page Delay can range from 0 (no added delay) to 3600 seconds (1 hour).

As with the Speed tab, this is an options tab for which Apply has no effect.
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6.7 Notifications settings
The Options > Notifications tab lets you configure reporting and notifica-
tion settings, including mobile notifications when a plot finishes. As with the 
Speed and Copies tabs, this is an options tab for which Apply has no effect.

The first two options on this tab are Report time elapsed when plotting or 
previewing, and Render pen movement when previewing.  The second item, 
Render pen movement, is not discussed until section §6.8 Preview mode, on 
page 72.

6.7.1 Report time elapsed 
When the Report time elapsed option is checked, a dialog box will report 
the elapsed time and pen-travel distance after each plot or plot preview.  

When used with Preview mode, this option can provide accurate estimates 
of how long a plot will take. (Preview mode is discussed in section §6.8 Pre-
view mode, on page 72.)

When Report time elapsed is checked and you use the Resume tab to re-
sume a stopped plot, note that the distance reported reflects pen-down dis-
tance from the beginning of the plot, not from where it resumed.
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6.7.2 Mobile/Online Notifications

The Bantam Tools NextDraw software has the ability to send notifications 
via when a plot finishes, using a specialized type of Internet request called 
a Webhook. This feature is disabled by default. Webhooks are a method of 
sending requests to various third-party services, frequently used for generat-
ing notifications such as mobile alerts.

Webhook notifications are sent when a plot ends (whether completed or in-
terrupted), but only when all four of the following conditions are met:

1. A document is being plotted with the Plot or Resume tab, 
2. The document is being physically plotted; Preview mode is disabled,
3. The Notify me check box is checked, which enables notifications, and
4. A Webhook URL is provided

Various online services exist to trigger actions upon receipt of a webhook 
post. Beyond notifications, Webhooks can be used for integration with other 
software or hardware, to trigger other actions that should follow a plot.
  
Online services that support Webhook functions for free or low cost include: 

•	 NTFY (ntfy.sh)
•	 Make (make.com; formerly Integromat)
•	 IFTTT (ifttt.com) 
•	 Zapier (zapier.com).

http://ntfy.sh
http://make.com
http://ifttt.com
http://zapier.com
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6.7.3 Setting up notifications with NTFY

Our recommended service for notifications is NTFY (ntfy.sh), a free service 
that can provide mobile or desktop notifications, and does not require that 
you create an account.

If you would like to set up mobile notifications on your phone or tablet with 
NTFY, the steps to do so are as follows:

1. Download the NTFY app for your device, following links at ntfy.sh .
2. In the NTFY app, click the “+” button to add a subscription.
3. For Topic name in NTFY, pick and enter your_topic_name
4. Press Subscribe to subscribe to that topic.
5. In the NextDraw software, check Notify me.
6. And, for Webhook URL, enter ntfy.sh/your_topic_name. 

In these steps, you pick a Topic name for the notifications. Topic names can-
not contain spaces or special characters.

Your Topic name should be something unique that no one will guess, so that 
you only send and see notifications that you intend to. 

If, for example, you were to use nextdraw_test_public as your Topic 
name, then anyone who subscribed to that Topic name in NTFY would be 
able to see when your plots finish, and, if you subscribed to that topic, you 
would get a notification any time that someone else using that same Topic 
name finished a plot.  In most cases, it is better to instead use a “secret” name 
that only you — and anyone else you want to give access to — can be notified.

You can also subscribe to NTFY topic notification on a regular computer: Visit  
ntfy.sh/app — As with the mobile apps, no account is needed.

http://ntfy.sh
http://ntfy.sh
http://ntfy.sh/app
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6.8 Preview mode

Preview mode is enabled when the Preview mode checkbox at the bottom 
of the Bantam Tools NextDraw control panel is checked. 

Checking the Preview mode checkbox does not, itself, perform any action. 
However, when you do press Apply, for example on the Plot tab, the soft-
ware will operate in Preview mode.

When Preview mode is enabled, most everything in the software will work 
normally, with the significant exception that the software will not connect to 
the NextDraw. Preview mode can be useful to test workflows, estimate timing, 
or otherwise preview how the NextDraw will plot a document, even without 
the NextDraw present.

Certain modes and commands that are primarily designed to communicate 
with the NextDraw over USB — including most in the Setup and Utility tabs 
— are unavailable while in Preview mode.

6.8.1 How to run a Plot preview
To run a Plot preview, check the Preview mode checkbox, select the Plot 
tab, and press Apply. 

Running a Plot preview performs all of the processing normally done in plot-
ting a document with the exception of sending the motion commands to the 
NextDraw.  This can catch any errors in processing the document.  

If the Report time elapsed option is checked in the Options > Notifications 
tab, a dialog box will report the estimated time and plot distance for plotting 
the document. This ability to estimate the time needed for a plot is one of the 
most useful features of Preview mode.

Preview mode can also be used with the Resume tab active, to simulate the 
process of resuming a plot.
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6.8.2 Preview mode rendering

An option available on the Options > Notifications tab is Render pen move-
ment when previewing. When checked — as is default — we say that Pre-
view mode rendering is enabled. 

Preview mode rendering simulates and “draws” the path of the NextDraw 
pen across the page when you run a Plot preview.  

Here is how the example file HelloWorld.svg looks when you click Apply from 
the Plot tab with Preview mode enabled and Preview mode rendering en-
abled:

Pen-down movement — where the NextDraw draws on the page — is ren-
dered in blue, and pen-up movement between paths is shown in light red.  

These preview paths are drawn on your page in a non-printing Documenta-
tion layer when you run a Plot preview.  (See section §6.3.4 Additional Layer 
Control features, on page 62 for more about Documentation layers.)
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6.8.3 Working with rendered previews
You can select from the menu Layer > Layers and Objects... to open the 
Layers and Objects panel to hide, show, or remove the Preview layers. Each 
time that you render a new preview it will overwrite the old one.

The pen-down drawing and pen-up drawing portions are rendered as sepa-
rate sublayers within the Preview layer, so that you can hide one, the other, 
or both.  (If you don’t see the sublayers in the list, use the triangle next to “% 
Preview” to expand its sublayers.)

Since previews are rendered within a documentation layer, these layers will 
not plot on the NextDraw, nor will their contents be rendered as part of fu-
ture preview renders. See section §6.3.4 Additional Layer Control features, on 
page 62 for more about Documentation layers.
 
Preview layers are erased and overwritten every time that you run a new pre-
view. Do not add any graphics or information that you want to keep to exist-
ing preview layers, as they may easily be overwritten.

In addition to using the Layers and Objects panel to hide or remove ren-
dered previews, you can also use the Strip plotter data from file option on 
the Utilities tab to remove rendered previews from your document.
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6.9 Advanced options
The Options > Advanced tab has additional options that control the behav-
ior of plots. As with similar tabs under Options, pressing the Apply button 
with the this tab selected has no effect: This tab on its own does not initiate a 
plot, perform homing, plot optimizations, or any other action.

The last two options, Hidden line removal and Plot optimization are dis-
cussed in the following sections, §6.10 Hidden-line removal, on page 77 
and §6.11 Plot order and optimization, on page 78.

6.9.1 Enable automatic homing
The Enable automatic homing option, checked by default, enables auto-
matic homing, on Bantam Tools NextDraw models. Uncheck this option in 
order to change the behavior, using manual homing only.

See section §3.2 Automatic and Manual Homing, on page 29 for more in-
formation about these two ways of using the machine.
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6.9.2 Auto-rotate page when printing
Documents taller than wide (those in portrait orientation) are normally rotat-
ed sideways when plotted.  To force documents to always print in the same 
orientation as on your screen, uncheck the Auto-rotate page when printing 
option.

See §4.3 Document orientation, on page 40 for more about how document 
orientation is determined.

6.9.3 Randomize starts of closed paths
A pen may form a visible mark at the location where it is lowered or raised. In 
artwork where the same closed shape is repeated many times, that can cause 
a seam-like visual artifact if many of those marks line up at matching points 
on the repeated shapes.

When Randomize starts of closed paths is enabled, the start position of 
closed paths — e.g., circles, rectangles, and squiggles that form a full loop 
with no obvious start or end point — will be randomized, which can help to 
hide that specific type of visual artifact.

As a demonstration, see the two figures below, each consisting of ten concen-
tric circles and plotted with a red pen:

The circles on the left were plotted with the option disabled, as is default. 
Starting at the center of the circles and looking to the right, you may be able 
to see a small visual artifact where the pen set down and lifted at each circle.

The circles on the right were plotted with Randomize starts of closed paths 
enabled. The visual artifacts are still present, but they are less noticeable be-
cause they do not line up.

Randomize starts: Off Randomize starts: On
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6.10 Hidden-line removal

The Hidden-line removal option in Options > Advanced changes document 
processing, such that objects hidden behind other objects will not print.

By default, with this option disabled, the NextDraw draws all paths in the SVG 
document. The fill and stroke (outline) properties of individual objects are 
ignored. In other words, all paths are normally plotted as though each has a 
stroke and no fill.

When Hidden-line removal is enabled, the NextDraw software will instead 
plot paths only if (1) they do have a stroke applied to them, and (2) they are 
not occluded behind filled objects. An object that does not have a stroke 
property (e.g., no outline in Inkscape) will not plot, nor will one hidden behind 
a solid fill. The example below illustrates these differences.

There are two important factors to bear in mind. First, Hidden-line removal 
requires additional processing time before plotting, especially in instances 
with large numbers of objects to process. (When you don’t need this feature, 
leave it turned off.)

Second, the Hidden-line removal processing routine does not preserve the 
orientation of individual SVG strokes. When you use it, we generally recom-
mend also using the Plot optimization option, set to Full; Also allow path 
reversal, for efficient plotting.
  

Default behavior:

Appearance in
Inkscape:

Hidden-line removal enabled:
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6.11 Plot order and optimization
The Plot optimization option in the Options > Advanced tab can re-order 
elements in your document to reduce pen-up travel, and thereby reduce to-
tal plotting time. 

6.11.1 How plot order is determined
Elements within a document are normally plotted in the same order in which 
they appear in the file. This order is generally the order in which the objects 
were created; it might also be figuratively referred to as “bottom to top,” as 
draws puts new objects “on top” of existing ones. 

For example, draw a circle and then a rectangle. Then, the NextDraw will plot 
the two objects in the order that you created them: The circle will plot before 
the rectangle. The rectangle can also be described as being “above” the cir-
cle— a description that makes sense if you imagine painting one object and 
then painting the other on top of it.

You can use the tools in the Object menu to rearrange the order of objects, 
for example with the Object > Raise and Object > Lower menu commands. 
If you raise our example circle above the rectangle, the rectangle will plot first. 

If a document has multiple layers, lower layers plot before higher layers; you 
may wish to open the Layers panel to see their order for reference.

6.11.2 Plot optimization options

The Plot optimization drop-down menu in Options > Advanced has four 
items:

•	 Least; Only connect adjoining paths (default)
•	 Basic; Also reorder paths for speed
•	 Full; Also allow path reversal
•	 None; Strictly preserve file order
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By default, most types of Plot optimization are disabled, and objects in the 
document will be plotted in the order given by the file. However if either “Ba-
sic” or “Full” is selected, then elements within the file will be reordered to 
reduce pen-up travel when you plot or run a plot preview from the Plot or Re-
sume tab. Detailed descriptions of these options follow in the next sections.

The optimization routine is layer-aware: It will only re-order objects within lay-
ers. That makes it safe to use on multicolor plots where colors are separated 
by layers. (See §6.3 Working with multiple layers and colors, on page 58.)

Changes to the order of elements during Plot optimization are ephemeral. 
A temporary copy of the file is created and re-ordered when you plot; no 
changes to the order of elements in your file are retained.  

Aside: There is an advanced method to save a file after optimization, for 
times when that’s helpful. See §7.5 Bantam Tools NextDraw Plob Export, 
on page 98.

6.11.3 Default: Least; Only connect adjoining paths
If the default option, Least; Only connect adjoining paths is selected, then 
paths in the document will plot in the same order and (if Hidden-line remov-
al is disabled) direction as given in the document.

One exception to note is that if one path ends right where another begins (on 
the same layer), those paths will be joined together, reducing the number of 
pen lifts needed. To disable path joining, select None; Strictly preserve file 
order.

6.11.4 Basic; Also reorder paths for speed
If Basic; Also reorder paths for speed is selected, the plotting order of ob-
jects within your document will also be altered to reduce pen-up travel.

Every graphical element within each layer will be broken into its constituent 
pen-down strokes, or “subpaths”, and those subpaths will be re-ordered. This 
optimization option preserves the direction of each subpath, if Hidden-line 
removal is disabled: Each subpath will be plotted from its start to its end, 
in the same direction that it appears in the file. For paths that are drawn by 
hand, this direction is normally the same direction in which it was initially 
drawn. 
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6.11.5 Full; Also allow path reversal
If Full; Also allow path reversal is selected, the same re-ordering processes 
are used. However, during the re-ordering process, the direction in which in-
dividual sub-paths are drawn may be reversed to reduce pen-up travel time. 
This option generally leads to the fastest overall plotting time. See §6.11.8 
Example: Path reversal, on page 83 for a visual example of path reversal.

6.11.6 None; Strictly preserve file order
The None; Strictly preserve file order option disables all re-ordering and 
path joining methods. Paths will plot in the order and (if Hidden-line remov-
al is disabled) direction as given by the document. This option is chiefly useful 
in scientific or engineering applications, or specialty use cases such as re-ink-
ing a brush, where the order of operations is programatically determined.

6.11.7 Example: Previews and optimization
When managing complex plots, it may be helpful to use Preview mode with 
Preview mode rendering (page 73) and Report time elapsed (page 
69) enabled, in order to preview what the plot order looks like and estimate 
the plotting time with different options.

As an example, here is a stipple drawing, created with StippleGen, consisting 
of about 4700 little round spirals, laid out on a letter-size sheet of paper. 
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For this example, the stacking order of the stipples within the file has been 
randomized, such that there is only a random order to which the filled circles 
appear in the file and how they will normally print.

If we enable Preview mode, Preview mode rendering, and Report time 
elapsed, and then run a Plot preview using the Plot tab, we get the following 
mess, where the blue lines represent drawing, and light-red lines represent 
pen-up travel:

The time report from this plot reads as follows:
Estimated print time: 57:47 (Minutes, seconds)
Length of path to draw: 31.079 m
Pen-up travel distance: 547.127 m
Total movement distance: 578.206 m
This estimate took 20 Seconds

As you can see by the numbers and the amount of pen-up travel shown in 
red, this plot is dominated by pen-up travel. Only about 5% of the travel is with 
the pen down. 

(continues)
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§6.11.7 Example: Previews and optimization, continued.

If we now enable plot optimization, selecting “Full” reordering and go back to 
the Plot tab to run the plot, we get the following, more pleasing result:

With optimization enabled, the statistics are as follows:
Estimated print time: 27:33 (Minutes, seconds)
Length of path to draw: 31.080 m
Pen-up travel distance: 15.748 m
Total movement distance: 46.827 m
This estimate took 21 Seconds

Thus, with Full optimization enabled, this particular plot now takes less than 
half the time: 28 minutes instead of 58. And, about 2/3 of the travel distance is 
spent with the pen down, a vast improvement over 5%.

Aside: While this is a stark example, many real-world documents do ex-
hibit this level of initial disorder, for example when you start with scanned 
and traced artwork, or documents generated programatically.
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6.11.8 Example: Path reversal
The path reversal option in Plot optimization can significantly improve per-
formance in some circumstances. This example drawing has 22 slightly vary-
ing curves, each drawn in the same direction, from top to bottom:

If we plot this with Preview mode and plot optimization set to Basic; Also 
reorder paths for speed, it neatly organizes the curves, and plots each of 
them in the original direction, top to bottom:

As you can see from the amount of (red) pen-up travel, a significant amount 
of the total motion is still with the pen up.

We can get a much more efficient result by using the Full; Also allow path 
reversal option for Plot optimization:
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6.12 The Configuration tab

The Options > Configuration tab allows you to specify which model of Next-
Draw hardware you are using, specify which particular NextDraw to plot to (if 
you are managing multiple machines), and check for software updates.

Press Apply with the Options > Configuration tab selected to check online 
for software updates.
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6.12.1 Selecting your model
The Model selection drop-down menu lets you select which model of plotter 
you are using. See §2.4 Select your model, on page 25 for more about this 
option.

6.12.2 Pen-lift motor option

As an addendum for the model selection, if you are using an AxiDraw with a 
brushless upgrade, then select Brushless upgrade for the Pen-lift motor op-
tion. For all other cases (a Bantam Tools NextDraw, an AxiDraw with standard 
or coreless pen-lift motor), leave this as Default for model. 

Advertisement: If you have an AxiDraw that doesn’t have a brushless pen-
lift motor, it’s a huge upgrade in speed, capability, and reliability. Consider 
getting one: bantam.tools/adbu

 

6.12.3 Machine selection

There are two additional controls in the Configuration tab that are relevant 
when working with multiple machines: the Machine selection drop-down 
menu and the Machine name or port text input box.

The Machine selection drop-down menu has three options:
•	 Use First located (default)
•	 Use machine named below
•	 Plot to all machines

If Use First located (the default option) is selected, the Bantam Tools Next-
Draw software will communicate the first NextDraw located via USB. Keep this 
option selected if you are working with a single machine.

http://bantam.tools/adbu
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§6.12.3 Machine selection, continued.

If Use machine named below is selected, the NextDraw software will only 
look for and drive a specific machine, as entered in the Machine name or 
port text entry box. Use this method when you have multiple machines to 
drive and want to plot to a specific machine.

The Machine name or port may be specified with a USB Nickname – like 
“California”  – or with a traditional enumerated serial port name like “COM6” 
on Windows or “/dev/cu.usbmodem1441” on a Mac. Since serial port names 
can change, it is best practice to use a USB Nickname when working with 
multiple NextDraw machines. (For more about USB Nicknames, see §7.3 Nex-
tDraw Naming, on page 94)

If Plot to all machines is selected, a document that is plotted will be simulta-
neously sent to all detected plotters. Use this option when you have several 
NextDraw machines and wish to plot the same document, simultaneously, on 
multiple machines. (A typical desktop-class computer can support up to 2-3 
NextDraw machines working simultaneously.)

When plotting the same document to multiple machines, any individual unit 
can be stopped by pressing its physical pause button, but plots that are 
stopped generally cannot be resumed.

6.12.4 Checking for updates
If you click Apply with the Options > Configuration tab selected, it will query 
and report both the versions of the Bantam Tools NextDraw software and 
the version of the NextDraw’s “EBB” firmware. Additionally, this function will 
check online to see if newer software versions are available.  We do highly 
encourage you to update to the latest available version.

As of the most recent edition of this user guide, the Bantam Tools NextDraw 
is shipping with firmware version 3.0.2. If you do need to update your firm-
ware, please visit bantam.tools/ndfw .

http://bantam.tools/ndfw
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6.13 Utility Functions
The Utility tab allows you to manually execute several basic and advanced 
commands that aren’t typically used in the course of everyday operation.  

Select the operation to perform from Command drop-down menu, and then 
press the Apply button. For certain commands, like the “walk” commands, 
you can also enter a distance.

The individual Command options are detailed in the following sections. 
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6.13.1 Walk Carriage commands
The first four manual commands in the Utility tab menu are Walk Carriage 
commands that move, or “walk” the carriage in the X or Y direction by the 
numeric distance given in the Walk distance field:

Walk Carriage (X, inches),  Walk Carriage (Y, inches)
Walk Carriage (X, mm),  Walk Carriage (Y, mm)

 
There are two different units (inches or mm) for each direction (X or Y). The 
distance to walk — in the selected units — is given by Walk distance, which 
may be positive or negative:

The Walk Carriage commands can be used to reposition the carriage or make 
small calibration adjustments to the carriage position before starting a plot, 
or (for example) while paused. This feature can be used to make tiny offsets 
to the initial position of a plot for fine-tuning alignment with different pens.

The position where a plot starts, if offset with Walk Carriage commands, is a 
temporary plot origin for that plot, and the carriage will return to that starting 
position when the plot ends.

Important note: no limit checking is performed on Walk Carriage commands; 
Take care not to run the NextDraw into its physical limits. If you are unsure, 
disable the motors and move the carriage Home by hand. Offsets made to 
the plot origin can also offset the plot position beyond the travel bounds of 
the machine. 
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+X

(0,0)

+Y

For reference, the Home corner is (by default) the X=0, Y=0 position. Positive 
moves in both X and Y are both in the directions away from Home. These 
directions are also shown by the Home label on the Left motor & electronics 
cover.
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6.13.2 Walk Home
The Walk Home command is a special “walk Carriage” type command that 
moves the carriage to the current Global Origin position. This is subtle, be-
cause that position may or may not be the same as the Home corner position.

When Automatic homing is active, the Global Origin position is normally the 
Home corner position, and so the Walk Home command will normally return 
the carriage to the Home corner.

With manual homing, the plot origin is the position where the motors were 
first energized. In normal operation, where the NextDraw is located in the 
Home position before enabling the motors, starting a plot, or using other 
Walk Carriage commands, Walk Home will return the NextDraw to the Home 
position. But, if the motors were enabled in some different position, this com-
mand will instead return the NextDraw to that position.

With either Automatic or manual homing, the Set Home command can be 
used to change the Global Origin, setting it to a new position after (for exam-
ple) using Walk Carriage commands.

The Walk Home  command can be used to reset the NextDraw carriage posi-
tion after one or more Walk Carriage commands or after pausing a plot that 
will not be resumed. 

6.13.3 Set Home
The Set Home command sets the current carriage position to be the “Global 
Origin” — the position to which Walk Home returns the carriage.

6.13.4 Raise the Pen, Lower the Pen
These two commands move the pen holder to the pen-up or pen-down po-
sition.

6.13.5 Toggle the pen up/down
This command moves the pen holder to the up position if it was down, and to 
the down position if it was up, when you press Apply.

6.13.6 Enable XY Motors, Disable XY Motors
These two commands either energize the two stepper motors or turn power 
off to them. The carriage can be moved by hand only when motor power is 
off.
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6.13.7 Enter Bootloader Mode
This command puts the Bantam tools NextDraw’s “EBB” control board into 
“bootloader” mode. This utility mode is sometimes used in reprogramming 
the firmware. If you should accidentally enter this mode, press the reset but-
ton to reboot the NextDraw.

6.13.8 Strip plotter data from file
The NextDraw software stores certain configuration data within your docu-
ment. This data includes the setup data necessary for resuming a file that was 
paused or otherwise stopped while printing.

While this data does not typically cause any issues, this command can strip 
that data from the file, should that need arise.

This command will also remove:
•	 Any ability to resume a plot that was paused
•	 Any “resume” warning about a plot containing a paused plot
•	 Rendered preview layers
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7. NextDraw Utilities
In addition to the main Bantam Tools NextDraw software, there are several 
additional programs included. Three can be found in the menu under:

Extensions > Bantam tools Utilities

One additional program, Bantam Tools NextDraw Plob Export, is only ac-
cessible when saving a file through File > Save a copy...

7.1 Disable XY Motors

Disable XY Motors can be found in the menu at:
Extensions > Bantam Tools Utilities > Disable XY Motors

This is a single-purpose “shortcut” command that turns off power to the mo-
tors that control the XY position of the NextDraw carriage.  Motor power is off 
by default at power up. This command is often useful to turn off power to the 
XY motors so that the carriage can be manually moved from one position to 
another, and in particular to the home corner, prior to plotting, when using 
manual homing.

This command is equivalent to using the Utility tab in the Bantam Tools Nex-
tDraw software, with Disable XY Motors selected. (See §6.13.6 Enable XY 
Motors, Disable XY Motors, on page 90.) 

This shortcut command is intended for use with a single machine; it performs 
the action on the first one located via USB. 
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7.2 Hatch Fill
The Hatch Fill utility can be found in the menu at:

Extensions > Bantam Tools Utilities > Hatch Fill...

Its usage is described in §8.11 Filling shapes and text, on page 113.

7.3 NextDraw Naming
The NextDraw Naming utility allows you to assign a USB Nickname to a spe-
cific machine.  It can be found in the menu at:

Extensions > Bantam Tools Utilities > NextDraw Naming...

A USB Nickname is a semipermanent label, stored in the flash memory of a 
Bantam Tools NextDraw or an AxiDraw.  This label may be used to identify 
and address that machine by name. USB Nicknames are not required, but 
can be helpful if you have more than one machine connected: You can use 
them to specify which machine to plot to from the Bantam Tools NextDraw 
software. See §6.12.3 Machine selection, on page 85.

Important note: USB Nicknames are semipermanent. Updating your Next-
Draw firmware will reset its configuration, removing any USB Nickname.

7.3.1 Read NextDraw Name
If you click Apply with the Read NextDraw Name tab selected, it will search 
for all attached machines and list them. They may be listed by their USB Nick-
name or by their USB port enumeration, if no USB Nickname has been as-
signed.  This tool can be useful for listing available machines, even if you are 
not using USB Nicknames. 
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7.3.2 Write NextDraw name
The second tab, Write NextDraw Name, is for writing a USB Nickname to a 
specific machine. 

To assign the USB nickname, enter a name between in the text box (here 
“Peekskill”) and click Apply. Before writing the name, it is recommended that 
you disconnect any other connected machines, so that you can be sure of 
which one you are writing the USB Nickname to.  

Writing an empty name will clear the nickname.

You can use the Read NextDraw Name tab to verify that the name has been 
written correctly. However, note that updates to USB Nicknames may not 
be visible until after resetting the machine manually and/or disconnecting it 
from USB.
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7.4 Snap Colors to Layers
The Snap Colors to Layers utility can be found in the menu at:

Extensions > Bantam Tools Utilities >  Snap Colors to Layers...

This utility helps you organize multi-color drawings by automatically sorting 
objects based on their stroke colors and optionally moving them into sepa-
rate layers. This is particularly useful when preparing documents for multi-col-
or plotting where you want to plot different colors with different pens, one 
layer at a time.

When you open the utility, you’ll see a panel with eight color slots. Each color 
has three associated controls:

•	 A color swatch that you can click to select a different color
•	 A Layer Name text field where you can specify the layer name
•	 An Enable This Color checkbox to include or exclude that color

The default layer names follow the format “1-black”, “2-red”, and so forth, with 
a leading digit that makes them easy to select by layer number when plotting 
(see §6.3.3 Selecting layers to print by number, on page 60).

At the bottom of the panel, you’ll find the Move objects to named layers 
checkbox. When checked, the utility will not only adjust stroke colors but also 
move objects into the corresponding named layers.

7.4.1 Using Snap Colors to Layers
The Snap Colors to Layers utility simplifies the process of preparing complex 
multi-color documents for plotting with the NextDraw, reducing the need for 
manual color adjustment and layer organization.

Before running Snap Colors to layers, we recommend that you save your doc-
ument, as this feature makes permanent changes to your file.  Then, open the 
utility and:

•	 Click any color swatch to open a color picker and select colors
•	 Check or uncheck the Enable This Color boxes to control which col-

ors are used
•	 Edit the Layer Name fields to match your preferred naming scheme
•	 If you want objects to be organized into layers as well as having their 

colors adjusted, check the Move objects to named layers option.
•	 Optionally, check the Live Preview option to see the effect of your 

settings before applying them.
•	 Click Apply to process the document.
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When the utility runs, objects with stroke colors in your document will have 
their stroke colors adjusted to the nearest enabled color from your list. If the 
Move objects to named layers option is checked, the objects will also be 
organized into layers named according to your specifications. 

Snap Colors to Layers, by default, operates on all objects in your SVG docu-
ment. However, if you select only some items before pressing Apply, then it 
will operate only on those selected items.

This utility is ideal for preparing multi-color plots when you want to:
•	 Standardize colors for visual consistency
•	 Reduce numerous similar colors to a manageable number of distinct 

colors
•	 Automatically organize objects into numbered layers for sequential 

plotting
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7.5 Bantam Tools NextDraw Plob Export
The Bantam Tools NextDraw software includes an advanced feature to ex-
port a “Plot Digest” or Plob file. A Plob is a pared-down SVG format that the 
software “digests” the file into, after processing, including hidden line remov-
al, cropping at travel bounds for a specific plotter model, and any random-
ization and optimization steps.  A Plob file is this intermediate state of the 
document, saved just before plotting. The name Plob originally comes from a 
contraction of “Plot Object.”

Opening and plotting from a Plob lets the NextDraw software start (or re-
sume) plotting almost immediately because it does not have to process the 
file again from scratch.

That speed gain can be helpful with very large SVG files that take a while to 
process before plotting, especially if you expect to pause and resume plotting 
several times.  You can also run a Plot preview from a Plob, with the same 
time savings. 

One common use case for Plob files is preparing and plotting files from dif-
ferent computers, especially when the computer that will do the plotting is a 
budget computer like a Raspberry Pi. 

To export a Plob, select File > Save a Copy... in Inkscape and then select file 
format NextDraw “Plob” Plot Digest (*.svg). 

Choose a name and location to save your Plob, and click Save to open the 
Bantam Tools NextDraw Plob Export dialog.
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In the dialog, select the options for your plot including the plotter model that 
you are preparing prepare the Plob for. Exporting a Plob takes as much time 
that it would for the NextDraw to begin plotting the file. However, you may be 
able to save that time when printing, since the NextDraw software can skip 
the initial processing and optimizations.

Important note 1: Generating a Plob is destructive. Always save as a copy with 
a new name and keep your original document.

Important note 2: You cannot make changes to a Plob after generating it. If 
you do, it will no longer be recognized as a valid Plob (and not skip process-
ing). Instead, modify and export a new Plob from your original document.
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8. Designing for NextDraw
8.1 General considerations
The Bantam Tools NextDraw is a pen plotter, which is fundamentally a single 
function device. Its sole function is to guide a pen (or other implement in the 
pen holder) along the set of vector lines, curves, and paths that you provide. 
All things that the machine is ultimately capable of – such as drawing graph-
ics, writing text, or signing documents – are expressions of this basic function. 
It is capable of drawing anything that can be composed from a set of lines. 

Certain object types are automatically treated as paths, for example circles 
and rectangles. Other types of objects that are made of curves – like text – 
may need to be converted from (editable) text into simple paths before plot-
ting. Many object types cab be converted to paths in Inkscape with the menu 
command Path > Object to Path.

8.1.1 Objects that are not paths
The NextDraw does not directly plot objects that are not made of paths. 

This includes pictures (raster or bitmap images, such as JPG, GIF, and PNG 
files), nor effects such as fills, gradients, and background colors. These kinds 
of things require conversion to paths before plotting. That is straightforward 
in some cases, and not in others. 

Two notable helper tools are the Hatch Fill extension (see §8.11 Filling shapes 
and text, on page 113) and the various third-party tools for converting imag-
es into sketches (see §8.12 Vectorizing images, on page 115).
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8.1.2 Importing graphics
The native file format of the NextDraw software is SVG (“scalable vector 
graphics” – a standard interchange format). You can create artwork directly in 
Inkscape or use other programs that can export SVG directly, such as Adobe 
Illustrator or CorelDRAW. Inkscape can also usually import artwork in formats 
including EPS, DXF, AI, CDR, and PDF, though going through SVG is more re-
liable.

If you encounter difficulties opening SVG documents in Inkscape, one ap-
proach that can help is to start with an empty document in Inkscape, and 
then use the File > Import command to place your document. See the next 
section, §8.2 Templates and document size, on page 102, for more about 
empty documents.

It is worth noting that the file type itself is not a reliable indicator of whether 
or not a file suitable for use on the NextDraw. For example, a PDF document 
with vector paths from Adobe Illustrator will generally work very well, but it 
is also possible to create a PDF that contains nothing but a picture in JPG 
format. In the latter case, the image still isn’t vector graphics, even though it’s 
tucked into a PDF file. 
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8.2 Templates and document size
When designing in Inkscape, it is recommended to create new documents by 
using a template, for example an A4 or US Letter sized document. 

In some cases, you may need to manually enter your document size.

The Bantam Tools NextDraw software will automatically clip and remove any 
paths in your document that exceed the document bounds when printing, 
so it is often helpful to match your document size in Inkscape to your actual 
paper size.

8.2.1 New from Template

You can create a basic document from a template by selecting File > New 
from Template, selecting a document size — such as US Letter (Landscape) 
— and pressing Create from template.
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8.2.2 The Document Properties window 
For other page sizes (not available within this panel), go to File > Document 
Properties... after creating a document. There, you can find a long list of stan-
dard paper sizes that you can choose from.

The Document Properties window also lets you custom enter the exact size 
of your document, select between portrait and landscape orientation, and 
pick the display units that are used in measurements and on-screen rulers.

If you frequently use page sizes that are not available in the Templates list, 
you may wish to save blank documents to use as your own templates.



104

8.3 Visualizing paths in your document
When working with documents containing mixed object types or styles, it can 
be helpful to visualize all of the paths without their fills. This is especially help-
ful when Hidden-line removal is disabled.
 
To see all of the paths in your document, select all in your drawing (From the 
menu: Edit > Select all in all layers). Then, open the Fill and Stroke panel 
(Object > Fill and stroke). In the Fill tab, select No paint, the “×” icon:

Then, in the Stroke paint tab, select “Flat Color”. And, in the Stroke style tab, 
select a consistent width, say 0.020 inches or 0.5 mm.

This procedure often provides a good visualization of how the NextDraw will 
view your page. However, it is not a precise representation of how plotting 
will work. For example, it shows the outlines around objects even if they are 
not yet converted to paths.

For a more exact preview of how your document will plot, use Preview mode 
with rendering enabled (see §6.8 Preview mode, on page 72). 
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8.4 Fonts, characters, and languages
The Bantam Tools NextDraw is designed to trace the vector paths that you 
provide to it. The document that you prepare can include any number and 
variety of different text and graphical elements, so long as they are converted 
to paths before you plot them.

As its sole function is to follow paths, the NextDraw hardware itself does not 
use fonts (built-in or otherwise) nor does it have knowledge about any writ-
ten languages. Thus, it has no preference for one language over another, 
and is equally happy to write in English, Japanese, or Arabic, so long as you 
can provide suitable input. Similarly, you can use fonts in any typeface style 
or character set – including international languages and including fonts that 
resemble handwriting.

Most fonts types like TrueType (TTF) and OpenType (OTF) that are installed 
on your computer are usable directly within Inkscape. You can create and 

edit text objects in Inkscape by selecting the text tool, which you 
can select by clicking the icon shown here, or by using F8 on your 
keyboard. You can select between available fonts using the Text 
and Font panel, accessible in the menu at Text > Text and Font....

To convert editable text into paths that can be plotted, select the text ele-
ments that you wish to convert. Then, choose from the menu Path > Object 
to Path. You may wish to save a separate copy of your document before 
converting to paths, in case you wish to edit the text again later. 

The text above was written in regular outline fonts, and converted using Ob-
ject to Path for printing.
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8.5 Outline fonts
All standard computer fonts — those found in formats including TrueType, 
PostScript, and OpenType — are Outline fonts. In outline fonts, each char-
acter in the font file describes a vector outline shape, which will be filled in by 
tiny pixels when displayed on your screen or rendered by an inkjet or laser 
printer. 

Things are different when you wish to use a pen plotter. As described in the 
previous section, you can easily convert outline font text into a set of paths 
for plotting, and then plot it with the NextDraw. When you do so, the machine 
will follow the actual vector paths in that font, which are those outlines. 

Below is a sample of text written in a common handwriting-like font:

The upper line of the sample shows the text filled in, as it will typically appear 
on your screen, or when printed on a laser printer. The lower line shows the 
outline: These are the actual vector shapes contained within the font file, and 
illustrates how the output will look when printed with a pen plotter.

Now, if you had picked that handwriting-like font with the intent of creating 
handwriting-like output on the NextDraw, this is probably not what you had 
intended.

The cause of this “unexpected” behavior is that one might easily (though mis-
takenly) assume that a handwriting-like font contains handwriting-like strokes. 
The letters “t” and “x” both look like they could be made up of two strokes that 
overlap, and the “O” looks like it could be a single loop. However, in order for 
outline fonts to render correctly on your screen, the “t” and “x” are instead 
each composed of a single (but complex) closed loop, while the “O” consists 
of two closed loops, one inside the other. 

To be quite explicit: there is absolutely no data contained within an outline 
font that represents or corresponds to the visually apparent centerline of the 
characters. This fact is consistent for all standard computer fonts, and will 
present no unexpected behavior, so long as you are aware of it.

Outline Font Example
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8.5.1 Handwriting-like output with outline fonts
When trying to achieve output close to that of natural handwriting, an “out-
lined” effect is not desirable. To mitigate it, pick handwriting-like fonts that 
have a thin and consistent stroke width. If a font is available in multiple weights, 
pick the lightest (thinnest) one available. This, combined with the use of a me-
dium or broad nib pen can often make it so that the two sides of the outline 
blend together. 

Using a broad-point pen, particularly a broad-nibbed fountain pen, is the one 
of the most effective ways to make a document look closer to hand written. 
It is also helpful to pick a larger font size, closer to that of natural handwriting 
(perhaps 18 pt) as a starting point. When writing by hand, people tend to 
write much larger than typical typed lettering.

8.5.2 Block and display output
In some cases you may wish to work with text that has large block letters, dis-
play text, or other instances with characters that have a wide cross section. 
Text like this will have a very visible outline, which you may or may not want 
to fill in with ink. 

The best way to fill in text is the Hatch Fill utility, as described in §8.11 Filling 
shapes and text, on page 113. When you apply a hatch fill, it will create a 
back-and-forth pattern for the pen to follow, to fill in the shape. While it may 
be counterintuitive to fill in text this way, it is actually closer to how outline 
fonts are intended to be used: The outline is filled in with ink.  
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8.6 Stroke fonts 
In addition to regular computer fonts (outline fonts), pen plotters like the 
Bantam Tools NextDraw can in some cases make use of a second class of 
specialized fonts, called Stroke fonts. In a stroke font, each visible character 
is defined by strokes of non-zero width, as opposed to the area within an out-
line. 

While they do have some restrictions, stroke fonts are ideal for use with pen 
plotters, since they plot efficiently (for example, the “o” is one loop, not two). 
They are particularly suited for handwriting-like applications, because they 
can closely mimic how humans write: Along the visual center lines of the text.

The following sample of text is rendered with a stroke font, using Hershey 
Tex., a basic stroke font tool that is now included with Inkscape. The second 
line is identical to the first, except that we have colored the individual paths 
(strokes) within each character so that you can tell them apart:

As you can see, characters like the “t” and “x” here are composed of two inter-
secting strokes. Similarly, a letter “o” in this font consists of a single loop. This 
particular stroke font is a single-stroke font, since each visible line is made 
up of only a single path. There are also some stroke fonts that use multiple 
strokes to construct wider characters, e.g., bold fonts.

There two important drawbacks to stroke fonts. First, they are not regular 
computer fonts, so they generally cannot be used in the same ways as other 
fonts. You cannot, for example, install them as regular fonts on your comput-
er nor use them in word processors or graphics applications. Second (and 
mostly because of that first reason) there are at present few available stroke 
fonts. Despite these obstacles, stroke fonts are still worth mentioning: In cas-
es where you can use them, they are the best solution for using fonts with a 
plotter.
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8.7 Hershey Text
Inkscape includes an application that we developed called Hershey Text, 
which is capable of typesetting text in a small number of included stroke-
based fonts. You can find it at Extensions > Text > Hershey Text.

Hershey Text takes editable text that you type and replaces it with rendered 
stroke-font text: Vector paths that the pen can follow. Once you have ren-
dered text into paths, it can no longer be edited as though it were text. 

To use Hershey Text, start with a document that contains text objects. Select 
the Render tab, and select a Font face from the drop-down menu. When you 
press Apply, it will render all text elements on your page into the selected 
stroke-based typeface. If you would like to convert only certain text elements, 
press Apply with just those elements selected. 

If the Preserve original text box is checked, then the original text elements 
on the page will be present after you Apply. If it is unchecked, then the origi-
nal font elements will be removed once rendered.

A full user guide for Hershey Text is available at: bantam.tools/hershey

http://bantam.tools/hershey
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8.8 NextDraw Merge & Stroke Font Utility
For users focusing on handwriting-like applications, the Bantam Tools Next-
Draw Merge software package is available for purchase separately.

This package contains two main software components: Bantam Tools Stroke 
Font Utility and Bantam Tools NextDraw Merge, as well as API versions of 
the Stroke Font Utility. 

Learn more at: bantam.tools/ndm

8.8.1 The Bantam Tools Stroke Font Utility
Bantam Tools Stroke Font Utility is a professional grade software package 
that lets you manage the process of working with stroke fonts to create fine-
tuned documents that look like genuine handwriting.

Like Hershey Text, the Bantam Tools Stroke Font Utility is a Inkscape Plugin 
to render plotter-ready stroke-based text. The Bantam Tools Stroke Font Util-
ity includes gorgeous new stroke fonts. It also offers the ability to introduce 
subtle “handwriting-like” defects, to help break the appearance of comput-
er-generated writing. And it provides full support for standard and custom 
third-party stroke fonts from Quantum Enterprises, including their “Scriptal-
izer” feature that can substitute multiple glyphs (character forms) into written 
text.

8.8.2 Bantam Tools NextDraw Merge
Bantam Tools NextDraw Merge Software automates the process of writing 
handwritten-like notes, labels, letters, and envelopes. 

It is a merge and machine control software for handwriting applications, 
which harnesses the full capabilities of both the Bantam Tools Stroke Font 
Utility and the Bantam Tools NextDraw software for Inkscape.

NextDraw Merge can, in a single step, perform stroke-font rendering on your 
document, complete with handwriting-like defects  — internally using the 
Bantam Tools Stroke Font Utility — and plot it on the NextDraw. It can plot 
the next document after a time delay or button press. 

You can also, optionally, use NextDraw Merge to automatically populate your 
template with data sourced from a CSV (spreadsheet) file before rendering 
the text, and repeat with data from subsequent rows of your CSV file. This is  
an enormously powerful workflow for creating beautiful, customized notes 
and letters. In addition to plotting, NextDraw Merge can also export stacks of 
rendered SVG documents, for use with other workflows.

http://bantam.tools/ndm
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8.8.3 The Bantam Tools Stroke Font Utility APIs
The Bantam Tools Stroke Font Utility also includes feature-complete com-
mand-line and Python APIs for rendering text. For scripting and automation, 
and other cases where using Inkscape is not appropriate, these APIs provide 
a means of directly rendering text within SVG documents.
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8.9 Capturing signatures and handwriting
The highest fidelity method to transform some handwritten text – whether  a 
single  signature or a full page of text — into something that the Bantam Tools 
NextDraw can plot is to use direct handwriting capture, or what you might 
refer to as “real-time” capture. 

In direct capture, you use your computer to record each stroke as it is written, 
and then save the resulting set of paths as a vector artwork file. This method 
can also be used when replicating handwriting. For example when replicating 
historical signatures, it is necessary to trace along the strokes of existing writ-
ing and to capture those strokes as you trace them.

For much more about ways to capture and trace handwriting — including a 
link to jSignature, a program that can easily capture your signature in real 
time — please see our detailed documentation about handwriting capture, 
found on our main NextDraw documentation site: 
	 bantam.tools/nddocs

It is worth noting that direct handwriting capture is the best possible way to 
digitize a signature, or other things that don’t need to change when they are 
written. For documents that need to be printed with different text each time, 
handwriting-like single-stroke fonts are a more appropriate solution. 

8.10 Aside: Tracing of scanned handwriting

While we are frequently asked about this, it should be noted that there is 
not any straightforward way of automatically converting scanned hand-
writing into a set of high-quality vector paths that a plotter such as the 
NextDraw can follow. Simple approaches such as centerline tracing rarely 
approximate the quality and character of real human handwriting.

This is a longstanding problem in artificial intelligence called “handwriting 
trajectory reconstruction.” Solving it is outside of what the NextDraw soft-
ware aims to support. (Again, the function of the NextDraw is to plot the 
vectors that you supply to it.)

When software that performs handwriting trajectory reconstruction be-
comes available, the NextDraw will be here, ready to plot its output.

http://bantam.tools/nddocs
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8.11 Filling shapes and text
The Bantam Tools NextDraw follows the actual vector paths in your docu-
ments, and thus normally ignores any “fill” inside shapes, since fills do not 
consist of vector paths. 

A special utility, Hatch Fill, is included with the NextDraw software that can fill 
shapes with vector paths – hatch marks – such that the shapes can be filled 
in with pen strokes on your page.  You can find it in the menu at:
	 Extensions > Bantam Tools Utilities > Hatch fill.

Hatch Fill will fill any selected objects with a series of back and forth lines, with 
adjustable spacing and angle. The hatch spacing is can be set in different 
units: Screen pixels, inches, or mm. The default value of 3 px is often a good 
starting value. A lower spacing will produce a more uniform fill, and a higher 
spacing will produce a  more traditional hatch fill for shading.  You can use the 
Live preview option to see the effects of different choices without actually 
applying them to your shapes and text.
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The Connect nearby ends option, enabled by default, connects the ends of 
the hatch lines to make long wiggling paths that plot very efficiently. An ad-
ditional option is provided for insetting the fill from the edges. This helps to 
avoid “coloring outside the lines” when using the hatch fill. 

Here are some examples of how different settings can be used in Hatch Fill. 
Each of the following are examples are shown actual size, with a 0.016 inch 
(0.4 mm) stroke width, similar to that of a fine rollerball pen. The Tolerance 
parameter was set to 1.0.

Examples (4) and (6) above — with a single hatch at 45 degrees, inset from 
the edges, and with the ends connected — usually give good results for most 
situations. The key parameter that you’ll need to adjust (based on the pen 
that you use and so forth) is the Hatch Spacing.

(1) No fill

(2): Spacing 3 px, Angle 0°.
Connect nearby ends: off
Inset: off

(5) Same as (4), but 
      with crosshatch: on

(6) Same as (4) but 
       with Spacing 1.0 px
       (crosshatch is off)

(4) Spacing 3 px, Angle 45°.
Connect ends: On, Range 3.
Inset: on, distance 1.0

(3) Spacing 3 px, Angle 45°.
Connect nearby ends: off
Inset: on, distance 1.0

Objects, including 
any applied hatches

The hatch fill
alone

§8.11 Filling shapes and text, continued.
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8.12 Vectorizing images
The process of turning images (JPG, PNG, photoshop files, etc) into vector art-
work is generally outside the scope of the Bantam Tools NextDraw software. 
That said, how to do so is a frequently asked question so we are including 
some notes on the subject.
 
The process of converting a photograph into a piece of pen-ready vector line 
art can most accurately be described by the word “sketching.”  That is to say, 
it is not so much a matter of file conversion as one of artistic interpreta-
tion. There are a limitless number of ways to represent a photo with a set of 
strokes. Artists that work with plotters often write their own programs to per-
form this kind of conversion, and we will point out a few of these programs.

Inkscape includes a vectorizing tool, found in the menu at Path > Trace bit-
map. It works by tracing the outlines of darker regions. It does work, and is 
sometimes useful for very simple shapes, but it generally does not produce 
high quality output that works well on plotters. You may end up with (for ex-
ample) ghostly effects, or tens of thousands of tiny little loops that represent 
stray pixels on the input photo.

A second approach to vectorizing images is to use a “squiggle” drawing pro-
gram. Tutorials for using three different Squiggle programs to create vector 
artwork are available at:  bantamtools.com/squiggle

http://bantamtools.com/squiggle
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Drawing Bot V3 is a third-party program that can render photographs into 
sketch paths, available in free and premium versions from: 
	 https://drawingbotv3.com

§8.12 Vectorizing images, continued.

https://drawingbotv3.com
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8.13 Importing from Adobe Illustrator
Adobe Illustrator users may notice two issues when working with SVG files 
imported from Illustrator into Inkscape. First, Inkscape does not automatically 
recognize layers in Illustrator SVG files, and instead usually treats them as 
regular groups. Second, the document and objects in it may be scaled down, 
at only 75% of the correct size.

Inkscape includes a tool that we developed for correcting these two issues in 
files imported from Adobe Illustrator. It can be found in the menu at:

Extensions > Document > Process Illustrator SVG

When you run this extension, it automatically detects any named Illustrator 
layers and sublayers in the file and converts them into named Inkscape layers 
an sublayers.  It also detects if the file is displayed at the 75% scale, and if so, 
scales it back to 100%. 

The user interface of the Process Illustrator SVG extension provides a list of 
the recommended steps to export SVG from Illustrator before opening it in 
Inkscape and running this extension. Amongst these steps, it is recommend-
ed to pick layer names in AI that contain at least one space, for example “1 
Lemon” or “Lemon yellow”, rather than “Lemon” or “1Lemon”.
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In Illustrator, export your file with:
File > Export > Export As...

Then, select SVG format, and check the “Use Artboards” option when saving:

The SVG Options window is displayed as part of the saving process. In it, 
select Presentation Attributes for styling, and Layer Names for Object IDs. 
Make sure that the Minify and Responsive options are not selected. 

Using this recipe for exporting SVG can solve any number of minor issues 
that we have seen in exporting from AI to Inkscape.

§8.13 Importing from Adobe Illustrator, continued.



119

9. Maintenance and troubleshooting
Bantam Tools NextDraw™ drawing machines does not require any regular 
maintenance under normal conditions.

9.1 Troubleshooting plot area
If you should find that the NextDraw does not appear to have access to the 
full plotting area of the machine, double check that you have selected the 
correct model of NextDraw in §2.4 Select your model, on page 25.

9.2 No lubrication required
The X carriage contains wheels that allow the X shafts and Y parts to slide. The 
wheels contain shielded and/or sealed ball bearing mechanisms that are per-
manently filled with grease. The pen-lift (Z) stage uses grease-free Teflon-filled 
plain bearings. NEVER apply oil or grease to any of the sliding mechanisms. 

9.3 Cleaning
Clean the Bantam Tools NextDraw only with a soft, clean cloth. The non-elec-
tronic metal parts may be cleaned with a cloth moistened with soap and 
water if needed. Avoid other cleaners and solvents. Do not wet the motors, 
cables, or controller board.

9.4 Storage
Store the Bantam Tools NextDraw with the carriage either in the Home po-
sition or (especially if it needs to be put away in a box) in the far opposite 
corner, fully extended such that the cable guides have the lowest profile. Un-
plugging the plug-in power supply when not in use for long periods of time 
will save power and prolong the life of the machine.

9.5 Belt tension
The Bantam Tools NextDraw uses a single timing belt, looped in an “X” shape 
around the two motors and the Y carriage. This belt may gradually stretch a 
small amount, and can be re-tensioned where it is anchored, if necessary. 
The necessary hex wrench (2.5 mm) is included with the NextDraw. Do not 
retension the belt unless it is actually necessary to do so.
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9.6 The wrenches
Three hex wrenches and two thin-profile crescent wrenches are included 
with the Bantam Tools NextDraw. The 2 mm ball-end wrench is used for 
switching the pen between the vertical and angled orientations. The others 
are provided in case more significant adjustments are required; they are not 
needed in most circumstances. However, if something should come loose, it 
is nice to have the right tools on hand. Contact technical support for guidance 
if needed.

9.7 Loss of position
The most significant thing that can go wrong under normal operation is a loss 
of position control while the carriage is moving. This is typically manifested as 
a loud grinding or screeching noise, along with pen marks not going where 
they are supposed to go. It can happen when moving at too high of a speed 
for the drawing conditions, or when the carriage hits an unexpected obsta-
cle– for example if it was bumped while moving (or if it was not moved to the 
Home Corner before plotting with manual homing).

If this should happen, press the pause button as soon as possible to cancel 
the plot. 

If you are using automatic homing on a Bantam Tools NextDraw, cycle the 
power off and on, which will cause it to perform a full homing cycle when you 
resume or begin a new plot.

If you are using manual homing, use Disable XY Motors to de-energize the 
motors, and then manually return the carriage to the Home Corner before 
trying to plot again.  

9.8 Wheel adjustments
The X and Y carriages roll on wheels that are tensioned against them. It is 
possible for these wheels to come slightly loose and need adjustment. If the 
NextDraw extended arm (Y carriage) seems loose or floppy, please contact 
technical support and we can walk you through the process.

9.9 Service, repair, and parts support
The NextDraw is designed to be serviceable, and we are here to help. Nothing 
should require regular replacement. However, most parts of the machine can 
be unscrewed and replaced if necessary. Please contact technical support 
directly if you need assistance with troubleshooting or repairing a mechanical 
issue.
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10. Bantam Tools NextDraw Tips and Tricks
1.	 It is often possible to get better print quality on top of a small stack of 

paper (say, 3-5 sheets) which gives a little cushion to your writing.
2.	 High quality paper – especially paper designed for use with pens – tends 

to give dramatically better results with pens than does cheap copy/laser 
paper. Bristol paper with a smooth finish is a great example of a paper 
designed to work well with pens.

3.	 The flatter that your paper is held, the better your print quality will be. 
Paper that is warped or “bubbled” will flex as the pen writes, leading to 
distortion. When the bubbles or warping are tall enough, it can also lead 
to stray marks on your page during pen-up movements. 

4.	 Reducing the amount of vertical pen travel that is needed will make your 
plots faster, and also improve print quality, since the pen-lift servo motor 
does introduce vibration.

5.	 When making multiple-color plots, you can get better registration when 
switching pens by making sure that each pen is set to the same height 
above the paper. A good way to do this is to rest the tip of the pen on a 
spacer when tightening the pen in place. Use a small, flat piece of wood, 
plastic, or metal. 

6.	 It is possible to completely detach the NextDraw pen holder, and affix 
other types of tools to the front of the Y carriage. Tapped M4 holes are 
provided for mounting other types of tool heads there. We also sell a “rig-
id end effector” accessory, for specialized use cases: bantam.tools/ree

7.	 Certain types of pens can “dry up” if left in the pen-up position for a min-
ute or two. This can lead to an awkward situation where ink does not start 
flowing until after the machine has already been drawing for a bit. With 
pens like this, it may be helpful to “bleed” out the tip with a bit of scratch 
paper before printing.

8.	 Styles applied to paths (width, color, etc) are normally ignored by the 
NextDraw software. If you have a dashed line and want it to plot with 
the dashes visible, you can use Extensions > Modify Path > Convert to 
Dashes to convert the dashes into separate path segments.

9.	 One of the simplest things that you can do to improve the quality of your 
output is to use a good quality pen. For handwriting applications, a medi-
um or broad-nibbed fountain pen, such as the Lamy Safari is an excellent 
starter choice.

10.	 Inkscape has a keyboard shortcut, Alt-Q (Option-Q on Macs), which will 
execute the last Inkscape extension once again. This is frequently useful 
when repeating a command, such as making one additional copy of a 
plot, without having to open the NextDraw Control panel again.

http://bantam.tools/ree
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11.	 You can also add your own keyboard shortcuts within Inkscape – for ex-
ample, maybe you want a shortcut for running the Disable XY Motors 
extension, or to open the NextDraw Control panel. To begin, open up 
Edit>Preferences (Windows, Linux) or Inkscape>Preferences (Mac), 
and select Interface>Keyboard Shortcuts from the left-hand column.

12.	 When saving graphics in SVG format from CorelDRAW, a helpful tip is to 
select the “Presentation attributes” option in the SVG export options. This 
typically helps to make the formatting work better in Inkscape.

13.	 The order in which objects on your page will plot is generally determined 
by the order in which they were initially drawn. “Lower” objects on the 
same layer will print before “higher” objects on the same layer. You can 
use the Object > Raise and Object > Lower commands to re-order ob-
jects. For more about plot order, see §6.11 Plot order and optimization, 
on page 78.

14.	 A range of Bantam Tools NextDraw accessories are available, including 
larger-size pen holders, extra easel boards, magnetic easels, mounting 
hardware and more. For details, please see bantam.tools/ndacc

§10. Bantam Tools NextDraw Tips and Tricks, continued.

http://bantam.tools/ndacc


123

Extended online documentation 
& resources for NextDraw:

bantam.tools/nddocs

Online Resources

store.bantamtools.com

bantam.tools/nddocs

bantam.tools/chat

bantam.tools/ndcontact

Store:

Docs:

Support chat: 

Contact resources:

http://bantam.tools/nddocs
https://store.bantamtools.com
http://bantam.tools/nddocs
https://bantam.tools/chat
http://bantam.tools/ndcontact
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